Firefox 10+: no more compatibility problems with ElasticFox

Finally, the Firefox team added one long-awaited feature – most add-ons are now compatible with the latest version by default (as long as they are compatible with Firefox 4)! This brings to an end the need for making ElasticFox work with each new Firefox version – from now on one only needs to do this once, in order to make it compatible with Firefox 4+, and that’s it! You can test all this by upgrading Firefox from older version (8 or 9 for instance) to the latest 10.0.2.

All add-ons compatibility problems were introduced with Firefox’s changed policy to six-weeks releases, so this feature  has been long-awaited.